Vulnerability

GLPI Two-Factor Authentication Bypass (CVE-2026-52848)

A two-factor authentication bypass in GLPI 11.0.0 through 11.0.7.

CVE ID
CVE-2026-52848
CVSS
9.2 Critical (CVSS v4.0, GitHub as CNA; NVD lists it as a secondary source); no CVSS 3.1 score in the record or NVD
Affected product
GLPI 11.0.0 up to but not including 11.0.8, per the CVE record
Exploited
Unknown
Published
4 November 2026 (CVE record and NVD); fixed in GLPI 11.0.8 on 24 June 2026

In short

CVE-2026-52848 is a two-factor authentication bypass in GLPI 11.0.0 through 11.0.7. An unauthenticated user can use a crafted URL during login to skip one-time-password verification. GitHub, the CNA, scores it CVSS 4.0 9.2 Critical, and GLPI 11.0.8 fixes it.

Profile MapVulnerability
  1. CVECVE-2026-52848
  2. ProductGLPI Project GLPI 11.0.0 up to but not including 11.0.8, per the CVE record
  3. Fix Steps5actions listedUpdate GLPI to 11.0.8 or Later · Check the Installed Version

What it allows

CVE-2026-52848 is an authentication bypass in GLPI, the open source asset and IT management package. The CVE record says that during the login phase an unauthenticated user can use a crafted URL to skip one-time-password verification. That defeats two-factor authentication on the affected releases.

The record files the weakness under CWE-288, authentication bypass using an alternate path or channel. GitHub, the CNA, titles it "MFA bypass" and scores it CVSS 4.0 9.2 Critical. The GLPI advisory GHSA-hgr8-qvp5-mhch says any user can use a self-crafted URL to make the two-factor protection ineffective.

What the Fix Changed

The only commit the CVE record links changes how GLPI decides whether a request is an API call. The old isAPI() function tested whether the request URI contained api.php or apirest.php anywhere. The new code checks whether the request path starts with one of them.

The advisory does not describe the mechanism, so this is our reading. A URL that only contained api.php may have been treated as an API request, and API requests follow a different login path. We have not traced the login code, so treat this as a lead for your own review.

Fixed Since June, Recorded in November

GLPI 11.0.8 was published on 24 June 2026, and the fix commit is dated the same day. The advisory carries the date 27 July 2026, while the CVE record was published on 4 November 2026. Anyone who patched in June or July already has the fix.

The 11.0.8 release is a security release with 16 fixes. It lists two Critical items, this MFA bypass and a remote code execution through form import (CVE-2026-48482). It also lists an account takeover through two-factor brute force (CVE-2026-49470).

What NVD and CISA KEV Say

NVD published the entry on 4 November 2026 and lists it as Deferred, with the GitHub CVSS 4.0 score as a secondary source. CISA's KEV catalog, version 2026.11.04, does not list the CVE. Our multi-factor authentication entry explains what the second factor protects.

Who is affected

The CVE record and the GLPI advisory list GLPI from 11.0.0 up to, but not including, 11.0.8. That means 11.0.0 through 11.0.7. The fixed release is 11.0.8, which the record, the advisory and the release page all name.

The record lists no other branch. The record does not say whether the 10.x line is affected, so we recommend checking the GLPI project's own release notes for the branch you run.

The advisory places the flaw in the login phase and says it makes the two-factor protection ineffective. We recommend treating any instance that relies on two-factor authentication as exposed until it runs 11.0.8. Our vulnerability management guide covers how to track a rollout like this.

Timeline

  1. 24 Jun 2026

    GLPI publishes release 11.0.8 with 16 security fixes, including this MFA bypass. The fix commit carries the same date.

  2. 27 Jul 2026

    GLPI publishes advisory GHSA-hgr8-qvp5-mhch.

  3. 4 Nov 2026

    GitHub publishes the CVE record. NVD publishes its entry and lists it as Deferred.

What to do

  1. Update GLPI to 11.0.8 or Later

    Release 11.0.8 fixes this bypass and 15 other security issues, two of them also rated Critical. Back up the database and files before the upgrade.

  2. Check the Installed Version

    Read the version in the GLPI interface or the install files. Any 11.0.x below 11.0.8 is in the affected range.

  3. Restrict Who Can Reach the Login Page

    We recommend keeping GLPI behind a VPN or an allowlist. An asset database holds data that helps an attacker move further.

  4. Review Login Logs for Odd URLs

    We recommend searching web server logs for login requests whose URL contains api.php or apirest.php in an unexpected place, and for successful logins without a one-time-password step.

  5. Reset Credentials if You Find Anything Suspicious

    Treat any account with a suspect login as compromised. Rotate its password and enrol the second factor again.

Questions

Which GLPI versions does CVE-2026-52848 affect?

The CVE record lists 11.0.0 up to but not including 11.0.8, so 11.0.0 through 11.0.7. GLPI 11.0.8 is the fixed release.

Do I need an account to use the bypass?

The CVE record calls the attacker unauthenticated, and the CVSS vector sets privileges required to None. The record does not say whether the attacker also needs a valid first factor.

Why is the CVSS score 9.2 and not 10?

The CVSS 4.0 vector sets attack requirements to Present, and the impact on subsequent systems to None. GitHub, the CNA, supplied the score.

Is there a CVSS 3.1 score?

No. Neither the CVE record nor NVD gives a CVSS 3.1 score. The only score is the CVSS 4.0 base score of 9.2 from GitHub.

In our research

  1. Multi-factor authentication (MFA) Glossary term

Sources

  1. CVE-2026-52848 Record CVE Program / GitHub CNA
  2. CVE-2026-52848 NVD
  3. MFA bypass, GHSA-hgr8-qvp5-mhch GLPI Project
  4. GLPI 11.0.8 release notes GLPI Project
  5. Fix commit 5ec327b GLPI Project
  6. Known Exploited Vulnerabilities Catalog CISA