Article
React’s RSC RCE Has No CVE, So Dependabot Stays Quiet
React RSC RCE (GHSA-xqc2-xf4c-x3h3) has no CVE id and no entry in GitHub's advisory database, so scanners stay quiet. Check versions by hand.
Quick links
Press Enter to search, Esc to close
Vulnerability
A critical, unauthenticated remote code execution flaw in React Server Components.
In short
GHSA-xqc2-xf4c-x3h3 is a critical, unauthenticated remote code execution flaw in React Server Components. React's advisory rates it 9.5 on CVSS 4.0 and names react-server-dom-webpack, react-server-dom-turbopack and react-server-dom-parcel as affected. The react/react repository published the advisory, and fixed versions, on 14 October 2026. It carries no CVE identifier.
React's advisory says crafted payloads targeting frameworks that support React Server Components can lead to remote code execution. React describes the condition narrowly, limited to responses that transport multiple typed arrays together with one attacker-controlled value. React calls these "extremely rare cases" and recommends updating immediately.
The fix sits in Flight, React's transport protocol for server components. Pull request #37846, titled "Improve transport protocol," changed 17 files and merged on 14 October 2026. Its description links three issues in a private mirror repository, so the technical root cause is not public.
The same-day advisory GHSA-h3gv-c5rc-p453 covers a separate denial-of-service condition in server function endpoints, rated 8.2 on CVSS 4.0, High. React says crafted HTTP requests to those endpoints can cause out-of-memory errors or excessive CPU use. The same four fixed versions close both advisories.
GitHub credits the finder of GHSA-xqc2-xf4c-x3h3 as the user evolutionstorm. The same user is credited as the finder of the same-day Next.js advisory, GHSA-673q-mjm6-r5xr.
There is no public report of exploitation in the wild found as of 8 Nov 2026. React's advisory does not state whether it has seen any attempted exploitation.
The advisory lists react-server-dom-webpack, react-server-dom-turbopack and react-server-dom-parcel as affected in versions 19.0.0 through 19.0.8, 19.1.0 through 19.1.9, 19.2.0 through 19.2.8 and 19.3.0. All three packages share the same fixed versions.
npm's registry shows all four fixed versions published on 14 October 2026, within minutes of the advisory. React's advisory says an app is not affected if its React code does not use a server. An app is also not affected if its framework, bundler or bundler plugin does not support React Server Components.
Next.js has a same-day advisory, GHSA-673q-mjm6-r5xr, from Vercel. Both advisories describe responses that carry multiple typed arrays and were published the same day. GHSA-673q-mjm6-r5xr affects Next.js 16.0.0 through 16.4.0 and is fixed in 16.4.1.
Next.js also shipped seven moderate advisories on 3 November 2026, in Next.js 16.4.5 and 15.5.29. Neither those advisories nor the 15.5.29 release notes state that the Next 15 line carries the GHSA-xqc2-xf4c-x3h3 fix, so Next.js users should check their react-server-dom package version directly. See our page on the Next.js use cache remote code execution, GHSA-673q-mjm6-r5xr.
React publishes GHSA-xqc2-xf4c-x3h3 and the same-day DoS advisory GHSA-h3gv-c5rc-p453 in the react/react repository. Fixed versions 19.0.9, 19.1.10, 19.2.9 and 19.3.1 reach npm the same day.
About 39 minutes later, Vercel publishes the Next.js twin advisory GHSA-673q-mjm6-r5xr and Next.js 16.4.1.
Vercel publishes Next.js 16.4.5 and 15.5.29 with seven moderate advisories; none states it carries the GHSA-xqc2-xf4c-x3h3 fix.
A request to GitHub's global advisory-lookup API for GHSA-xqc2-xf4c-x3h3 returns no record (our own check).
Check your lockfile, not just package.json, for react-server-dom-webpack, react-server-dom-turbopack and react-server-dom-parcel. Versions 19.0.0 to 19.0.8, 19.1.0 to 19.1.9, 19.2.0 to 19.2.8 and 19.3.0 are affected.
Move to 19.0.9, 19.1.10, 19.2.9 or 19.3.1, whichever line your app already tracks. All four were published to npm on 14 October 2026.
Next.js apps should also move to 16.4.5 or 15.5.29, the current security releases. No source states that the Next 15 line carries this React-side fix, so verify your react-server-dom version directly rather than trusting the Next.js version alone.
GitHub's global advisory database had no entry for GHSA-xqc2-xf4c-x3h3 on 8 Nov 2026. Tools that read that database will not flag it, so check versions by hand.
GHSA-h3gv-c5rc-p453 is a separate denial-of-service flaw in server function endpoints, fixed by the same four releases. One upgrade closes both advisories.
No. GitHub's global advisory database had no entry for it on 8 Nov 2026, and the react/react repository advisory lists no CVE identifier.
react-server-dom-webpack, react-server-dom-turbopack and react-server-dom-parcel, in versions 19.0.0-19.0.8, 19.1.0-19.1.9, 19.2.0-19.2.8 and 19.3.0. Update to 19.0.9, 19.1.10, 19.2.9 or 19.3.1.
There is no public report of exploitation in the wild found as of 8 Nov 2026. React's advisory does not state whether it has seen any attempted exploitation.
No. Both describe responses that carry multiple typed arrays and were published the same day, but they are separate advisories in separate repositories, and neither names the other.
Update to Next.js 16.4.5 or 15.5.29, the current security releases, and separately verify the react-server-dom package version. No source states that these Next.js releases carry the GHSA-xqc2-xf4c-x3h3 fix.
Take control of your digital security with an exclusive demo of our AI-driven threat intelligence platform.